Jump to content
×

Welcome to Celica Club UK

Welcome to Celica Club UK, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information. Take advantage of it immediately, Register Now or Sign In.

  • Start new topics and reply to others
  • Subscribe to topics and forums to get automatic updates
  • Add events to our community calendar
  • Get your own profile and make new friends
  • Customize your experience here
  • Use the wealth of knowledge our members have to help with any questions you may have.

Rehs

Club Member
  • Content Count

    11
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Rehs

  • Rank
    L-Plates
  • Birthday January 17

Profile Information

  • Gender
    Male
  • Location
    Kent, Rochester/Maidstone
  • Interests
    Cars, bikes, going fast. Duh
  • Model
    Celica gen 7

Recent Profile Visitors

70 profile views
  1. So I recently did a full recharge on my a/c and the machine detected no leaks hence why it let me refill the system. After this the AC worked amazing. It worked a week ago but after trying it today it no longer blows cold cold. I checked the AC pipes and the high pressure side is getting super hot which tells me there is gas and enough pressure for the pump to engage. On the other side of the compressor and the other side of the condensor the pipes are all just normal tempreture. Not hot or cold. Does anyone have any clue as to what this could be?
  2. Welcome to Celica Club UK. Please feel free to browse around and get to know the others. If you have any questions please don't hesitate to ask.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

Follow @celicaclubuk
All pages © celica-club 2001 - 2019 (Unless otherwise stated). No pictures can be used without our consent. Terms of use | Privacy policy