Celica Club UK Messages

Website Downtime Notice

Click here for more information

Welcome to Celica Club UK

Welcome to Celica Club UK, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information. Take advantage of it immediately, Register Now or Sign In.

  • Start new topics and reply to others
  • Subscribe to topics and forums to get automatic updates
  • Add events to our community calendar
  • Get your own profile and make new friends
  • Customize your experience here
  • Use the wealth of knowledge our members have to help with any questions you may have.

  • 0
Spannermac

Lambda sensor Q

Question

Hi guys quick one here..

 

Need a lambda front sensor for a 190 vvtli..

 

Question is would i be able to use asensor from the140 or does it need to be a 190?

 

Cheers

Share this post


Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0

Hi there! Don’t take this as gospel but I’m almost certain it’s got to be the 190 vvtli specific sensor as the one for the 140 is slightly shorter from what I remember when I changed mine a few years back. Also there’s 2 sensors pre and post cat. Hope this helps. 

Share this post


Link to post
Share on other sites
  • 0

Just had a quick look on Euro car parts and they are both same part number... Can onky guess meaning same type so gonna take a punt i think see how it goes.

Share this post


Link to post
Share on other sites
  • 0

Yeh it may be worth taking yours out and measuring it then looking on the Eurocarparts site at the spec for the ones they have available, it’s got the length of them in the description. I’ve got some old ones in the garage at home but unfortunately I’m not at my place at the mo or I’d check them for you. Let me know how you get on.


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
  • 0

Cable on the 140 one is too short to fit the 190 - that is for pre-cat

 

Post cat is the same

Share this post


Link to post
Share on other sites
  • 0

Sorry to bring this back up.

 

But I was wondering which sensor you chose to get in the end?

 

I keep getting the P0420 error code and am looking to change the front (pre-cat) sensor.

 

I've had a look online and have found two possible options - 

 

- DOX-0106 or DOX-0273, I think 0273 is for pre-facelift and 0106 is for facelift. If someone with more knowledge could confirm this?

Share this post


Link to post
Share on other sites
  • 0

This is what I got for a 2005 T-Sport (so FL) for the pre cat sensor:

 

  • 1 x DENSO Direct Fit Lambda Sensor - DOX-0273 - Oxygen / O2 - Genuine OE Part - Single

Share this post


Link to post
Share on other sites
  • 0
On 3/3/2018 at 10:29, LucyLou said:

This is what I got for a 2005 T-Sport (so FL) for the pre cat sensor:

 

  • 1 x DENSO Direct Fit Lambda Sensor - DOX-0273 - Oxygen / O2 - Genuine OE Part - Single

 

 

Awesome. Thanks! 

Share this post


Link to post
Share on other sites
  • 0
On 3/2/2018 at 23:25, mister_fcx said:

Sorry to bring this back up.

 

But I was wondering which sensor you chose to get in the end?

 

I keep getting the P0420 error code and am looking to change the front (pre-cat) sensor.

 

I've had a look online and have found two possible options - 

 

- DOX-0106 or DOX-0273, I think 0273 is for pre-facelift and 0106 is for facelift. If someone with more knowledge could confirm this?

 

 

420 is cat not sensor

Share this post


Link to post
Share on other sites
  • 0
On 3/8/2018 at 22:02, ams said:

 

 

420 is cat not sensor

 

 

Oh, that's probably due to the aftermarket cat that was fitted when the exhaust was done. 

 

They're not too expensive, so I might change it for peace of mind :)

Share this post


Link to post
Share on other sites
  • 0

Wont do any harm changing it but if you have a sports cat with a low cell count then the code is just telling you that its not good enough

Share this post


Link to post
Share on other sites