Welcome to Celica Club UK

Welcome to Celica Club UK, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information. Take advantage of it immediately, Register Now or Sign In.

  • Start new topics and reply to others
  • Subscribe to topics and forums to get automatic updates
  • Add events to our community calendar
  • Get your own profile and make new friends
  • Customize your experience here
  • Use the wealth of knowledge our members have to help with any questions you may have.

hoopsontoast

Club Member
  • Content count

    128
  • Joined

  • Last visited

Community Reputation

35 Excellent

About hoopsontoast

  • Rank
    Cruising
  • Birthday 31/08/87

Profile Information

  • Gender
    Male
  • Location
    Oxford/Swindon
  • Model
    ST182

Recent Profile Visitors

121 profile views
  1. Hi again, I have been having issues with air in the coolant system of my ST182, and the engine getting hot in places (while at idle, start driving again and it quickly comes back down) and more recently after bleeding the system it was fine for a ~300mile round trip on motorway/country roads, then after a few days back to the same problem. Part of the problem was the Radiator Cap was siezed shut, so any pressure could not be released, and on one trip a month back, after some time on the motorway, stopped at some services and the car did a wee from the bottom radiator hose. Filled it back up, bled the system and seemed to be OK apart from sometimes getting air locks and getting hot, quickly coming back down again after though. This was replaced last week. This week I have drained the coolant system, flushed it, refilled with some Wynns Radiator Flush heat up for 15-20min then flush again and refill with coolant. Been running for 20-min now and fine, no issues on getting hot at all. While waiting around, had a look at the damp patch that I thought was caused by the thread below, and it seems to be coolant under the passenger footwell, not oil as I first thought. The passenger carpet was damp, but underneath the wadding is sodden and there is a small pool of 'rusty' looking liquid on the bare metal footwell. No issues with rust anywhere, and no drips/smears down the side at any places. I suspect this may be my cause of the air in the system, if coolant is in the cabin, not where its supposed to be! Really at a loss now, took out the glovebox/speaker and there are no leaks anywhere other than a tiny bit of moisture at the location in the photo above (although now is clear liquid rather than oily. The hole above, is located right next to the heater matrix temperature control lever, you can see the lever just to the left. So I assume its heater related, which might fit in with the coolant issue, rather than being part of the air-con system next to it. Any thoughts?
  2. Happy Birthday hoopsontoast!

  3. Happy 4 Anniversary Phatdanuk!

  4. Happy 1 Anniversary hoopsontoast!

  5. And another Celica by Robert Seymour, on Flickr
  6. what have you done to your celica today...

    Thanks to Andy (Banjo99uk) I now have the original bonnet back on the Celica. Celica by Robert Seymour, on Flickr
  7. Celica sans Scoop Celica by Robert Seymour, on Flickr
  8. Happy Birthday hoopsontoast!

  9. Celica by Robert Seymour, on Flickr
  10. Celica by Robert Seymour, on Flickr
  11. Toyota by RSdesignUK, on Flickr
  12. On the way to work the other day:
  13. Thanks very much! Two different evenings, only stopped for around 5-10min. Photos were 30sec for the first and 6sec for the second.
  14. I revisited the previous shot.... Celica by RSdesignUK, on Flickr
  15. Toyota Celica by RSdesignUK, on Flickr